Service Issue - NSW

Incident Report for PEXA

Resolved

The reported issue impacting services in New South Wales is now resolved.

Lodgement is now now operating as normal.

This was not an issue on PEXA's side
Posted Jun 26, 2025 - 11:46 AEST

Monitoring

The issue that was impacting services in New South Wales is now resolved.

Lodgement is now working as normal.

We apologise for any inconvenience caused to you and your clients.

We thank you for your patience and will provide you with an update in an hour.
Posted Jun 26, 2025 - 10:48 AEST

Investigating

We are currently investigating an issue impacting services in New South Wales.

This means that there may be delays with Lodgement.

We’ll provide you with an update within the hour.

Thank you for your patience.
Posted Jun 26, 2025 - 10:33 AEST
This incident affected: Workspace Creation, Document Preparation & Lodgement Services (NSW).