PEXA Performance Issue

Incident Report for PEXA

Resolved

The previously reported issue causing system latency within the PEXA Exchange is now resolved.

PEXA system performance is back to normal and operating as expected.
Posted Jun 23, 2025 - 17:57 AEST

Update

We’re currently investigating reports of slow response times with PEXA’s platform.

We’re sorry for the inconvenience this is causing you.

We’ll provide you with an update within the hour.
Posted Jun 23, 2025 - 16:27 AEST

Update

We’re currently investigating reports of slow response times with PEXA’s platform.

We’re sorry for the inconvenience this is causing you.

We’ll provide you with an update within the hour.
Posted Jun 23, 2025 - 15:28 AEST

Update

We are continuing to investigate this issue.
Posted Jun 23, 2025 - 14:47 AEST

Investigating

We’re currently investigating reports of slow response times with PEXA’s platform.

We’re sorry for the inconvenience this is causing you.

We’ll provide you with an update within the hour.
Posted Jun 23, 2025 - 14:23 AEST
This incident affected: Financial Settlement Services.