Service Issue - SA

Incident Report for PEXA

Resolved

The delays with RevenueSA's stamp duty verification has been resolved. This was not an issue on PEXA's side.
Posted Jun 17, 2025 - 16:44 AEST

Monitoring

The issue that was impacting Stamp Duty in South Australia is now resolved.

Stamp Duty Verification is now working as normal.

We apologise for any inconvenience caused to you and your clients.

We thank you for your patience and will provide you with an update in an hour.
Posted Jun 17, 2025 - 15:29 AEST

Update

We are continuing to investigate this issue.
Posted Jun 17, 2025 - 14:54 AEST

Update

We are continuing to investigate this issue.
Posted Jun 17, 2025 - 13:51 AEST

Investigating

We are currently investigating an issue impacting Stamp Duty Services in South Australia.

This means that there may be delays with Stamp Duty Verification.

We’ll provide you with an update within the hour.

Thank you for your patience.
Posted Jun 17, 2025 - 12:56 AEST
This incident affected: Stamp Duty Services (SA).