Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 21, 2026 - 22:00 AEDT
Scheduled
PEXA will be undergoing scheduled system maintenance on Saturday 21 March 2026 from 10:00pm to 4:00am (AEDT).
You can continue using PEXA. However, you may experience: - Slower system response time. - Temporary feature unavailability. - In rare cases, you may be logged out. Please log back in to continue as normal or wait until the maintenance is complete.
Thank you for your patience and understanding.
Posted Mar 20, 2026 - 11:30 AEDT
This scheduled maintenance affected: Workspace Creation, Document Preparation & Lodgement Services (VIC, NSW, QLD, WA, SA, ACT, TAS, NT).